Mozilla L10N フォーラム一覧 Mozilla 製品 とその関連ソフトの日本語化に関するフォーラムです。
フィードバック方法や変更履歴などは Github をご覧ください。
 よくある質問  •  検索  •  登録ユーザ一覧  •  グループ   •  登録  •  ユーザ設定  •  ログインして PM を確認  •  ログイン
 1.6a日本語インストーラ Optimoz/Adblockが使用できない 次のトピックを表示
前のトピックを表示
トピックの新規投稿返信
投稿者 メッセージ
hyousuke
ゲスト





記事 件名: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 17:58 引用トップに移動

mozilla-win32-1.6a_1-ja.exe を使わせていただきました。

拡張のOptimozやAdblockをインストールし、インストールは成功しているようなのですが、(installed-chrome.txtに登録されていることで成功と判断)
使用可能になりません。

Optimozの場合は、Preferencesの 詳細->Mouse Gesturesが現れない
Adblockの場合は、メニューのツール(T)にAdblockが現れない
といった状況です。

OptimozもAdblockも、mozilla.orgが配布しているインストーラでインストールしたmozillaにインストールしたところ、使用可能でした。

とりあえず、報告させて頂きます。

Optimoz
Adblock
hyousuke
ゲスト





記事 件名: Re:1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 18:09 引用トップに移動

うっ、すいません。
「Mozilla 日本語インストーラ Windows 版 不具合報告・ご要望 用」に返信すべきだったのですね。(new topicにしてしまいました)
以後気をつけます。目障りなようでしたら削除/移動してください…
ふぉーちゅん



登録日: 2003年10月 06日
記事: 250

ユーザ情報を表示メッセージを送信メールを送信
記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 19:32 引用トップに移動

hyousuke wrote:

Optimozの場合は、Preferencesの 詳細->Mouse Gesturesが現れない
Adblockの場合は、メニューのツール(T)にAdblockが現れない


不具合報告ありがとうございます。当方でも何度か実行したところ現象が再現しました。これは XUL キャッシュの問題が発生しているのではないかと考えます。

オプションモジュールをインストール後に項目が現れない場合は、Mozilla を停止して、プロファイルフォルダの XUL.mfl を削除して頂き、再度 Mozilla を起動して下さい。

→ 問題が改善しない場合は再度ご連絡下さい

なお、言語/コンテンツ に en-US(更新が必要です) 等と表示されますが、en-US 等をアンインストールをしてしまうとオプションモジュールの GUI が消えてしまうのでご注意下さい。


ふぉーちゅんが2003年11月03日(月) 20:37にこの記事を編集, 編集回数: 1
ゲスト






記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 19:55 引用トップに移動

hyousuke wrote:
mozilla-win32-1.6a_1-ja.exe を使わせていただきました。

拡張のOptimozやAdblockをインストールし、インストールは成功しているようなのですが、(installed-chrome.txtに登録されていることで成功と判断)
使用可能になりません。

Optimozの場合は、Preferencesの 詳細->Mouse Gesturesが現れない
Adblockの場合は、メニューのツール(T)にAdblockが現れない
といった状況です。

OptimozもAdblockも、mozilla.orgが配布しているインストーラでインストールしたmozillaにインストールしたところ、使用可能でした。

とりあえず、報告させて頂きます。

Optimoz
Adblock
 Optimozに関しては、もじら組BBSにて報告されているものと同じではないでしょうか。要は、Optimoz添付のJLPのバグです。本家のパッケージの場合、英語リソースを使用しようとする為に表面化しないわけです。
ふぉーちゅん



登録日: 2003年10月 06日
記事: 250

ユーザ情報を表示メッセージを送信メールを送信
記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 20:36 引用トップに移動

Motohiko wrote:
Optimozに関しては、もじら組BBSにて報告されているものと同じではないでしょうか。要は、Optimoz添付のJLPのバグです。本家のパッケージの場合、英語リソースを使用しようとする為に表面化しないわけです。


おお、nightly では日本語化されているのですね。しかし、表示が現れないとのことですので hyousuke さんの問題は XUL キャッシュの問題と考ええます。リリース版 Version 0.3.5.1 の英語の利用には特に問題がありません。

nightly を使ったところ BBS のような内容の問題が再現し、もとひこさんの修正 JLP で修正されることを確認しました。

#マウスジェスチャはインストーラに組み込んで欲しいという要望が多いので標準での JLP 組み込み大いに期待しています。
ゲスト






記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 20:38 引用トップに移動

Motohiko wrote:
 Optimozに関しては、もじら組BBSにて報告されているものと同じではないでしょうか。要は、Optimoz添付のJLPのバグです。本家のパッケージの場合、英語リソースを使用しようとする為に表面化しないわけです。

XUL.mflの削除で、adblockは解決(しまった…基本でしたね)。Optimozに関してはもじら組BBSにあったもとひこ氏のJLPをインストールすることによって解決しました。ありがとうございました。

ところで
ふぉーちゅん wrote:
# これらのまだ標準にはなっていない(かつ誰も日本語パックを作っていない)オプションと日本語インストーラをどう組み合わせるかはなかなか難しい問題です。

ということは、この他にもインストールすると問題の出る拡張がありそうな感じですね。
現状でJLPの存在しない拡張を使用したい場合は、日本語インストーラではなく、英語リソースが含まれている本家配布のパッケージを使用した方がよい、ということでしょうか。
#に返信していいのかな(笑
ふぉーちゅん



登録日: 2003年10月 06日
記事: 250

ユーザ情報を表示メッセージを送信メールを送信
記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 21:10 引用トップに移動

hyousuke wrote:
ということは、この他にもインストールすると問題の出る拡張がありそうな感じですね。
現状でJLPの存在しない拡張を使用したい場合は、日本語インストーラではなく、英語リソースが含まれている本家配布のパッケージを使用した方がよい、ということでしょうか。
#に返信していいのかな(笑


私の方もここに返信する内容ではないかも知れませんが…。

言い方が大げさでしたが、基本的には「言語/コンテンツ に en-US(更新が必要です) 等と表示される」という問題があるだけです。気持ち悪いというそれだけです。

#主要なオプションを取り込んで欲しいという要望を割と受けているのですが、英語だけのオプションはこれを避けられないので、まだうまくいくものが少ない状況です。

なお、日本語インストーラのインストール後の状態は、英語版に JLP を入れた後に en-US をアンインストールし、かつ手動で default 以下の初期プロファイルを米国向けから日本向けに置き換えたのと同じ状態です。パッケージングでミスしたときのみ独自の問題が発生することになります。

では、なぜ英語リソースを完全に削除するかというと Mozilla の連続起動試験をしていると、特に高速起動のタスクトレイのアイコンから起動しているとある程度の確率で英語で立ち上がってきます(何人かから報告され、英語版や和ジラでも再現します)。原因は不明で、これを避けるためには英語リソースを消しておくしかないのが現状だと思っています。

ということで、話がそれましたが、下記は基本的には日本語インストーラとは別問題です。

- XUL.mfl の問題
- Optimoz の nightly の JLP のバグ
hyousuke



登録日: 2003年11月 03日
記事: 1

ユーザ情報を表示メッセージを送信
記事 件名: Re: 1.6a日本語インストーラ Optimoz/Adblockが使用できない     投稿時間: 2003年11月03日(月) 21:54 引用トップに移動

ふぉーちゅん wrote:
(中略)
ということで、話がそれましたが、下記は基本的には日本語インストーラとは別問題です。

- XUL.mfl の問題
- Optimoz の nightly の JLP のバグ

はい。了解です。問題の後に本家パッケージで追試したらすんなりいったので、早合点したようです。お手数をお掛けいたしました。
RESOLVED INVALIDというところでしょうか Embarassed
#名前間違えてましたね。なんか間違い多すぎで恐縮です
指定期間中に書かれた記事を表示:      
トピックの新規投稿返信


 別のフォーラムに移る:   



次のトピックを表示
前のトピックを表示
新規トピックを投稿できます
既存トピックに返信できます
自分の記事を編集できません
自分の記事を削除できません
投票に参加できません


Powered by phpBB © 2001, 2002 phpBB Group (customized by dynamis) :: FI Theme :: All times are GMT +9:00